Author Topic: Instruments and ECU problems after long storage  (Read 350 times)

Offline barefootrider

  • New Goose
  • *
  • Posts: 2
  • Location: Miami, FL
Instruments and ECU problems after long storage
« on: May 02, 2021, 12:48:14 PM »
Hello,

I have a very nice 2004 Breva 750 that has always worked well until I came back from overseas and tried to get it running again after nearly 5 years in storage. I checked every sensor and every wire going to the ECU ( IAW 15RC . C8 ) and the instrument panel connector. Everything looks to be OK but it won't start the fuel pump and won't fire the coils, needles go up to full scale, then down, all indicator lights are dead except the high beam indicator.
Any clues? Is there an immobilizer that could cause this?

Any help would be appreciated,

Thanks
Bruno


Online rtbickel

  • Guzzi Mentor
  • ****
  • Posts: 828
  • Location: Dallas
Re: Instruments and ECU problems after long storage
« Reply #1 on: May 02, 2021, 01:36:46 PM »
Stuck relay?
2020 V85TT
2002 California Special Sport - The Black Widow
2014 California Touring - Stealth (Gone but not forgotten)

Online Kiwi_Roy

  • Guzzi Hero
  • *****
  • *
  • Posts: 9084
  • Location: New Westminster BC
Re: Instruments and ECU problems after long storage
« Reply #2 on: May 02, 2021, 11:13:11 PM »
https://www.thisoldtractor.com/guzzi007/schematics/2004_750_Breva.gif
I'm guessing one of the two main relays Main Injection Relay (11) or Secondary Injection Relay (12) are not closing.
Double check you have the battery in the right way, it may crank but the ECU will not be powered up if the battery is connected backwards, the Main Injection Relay has a diode inside called the Safety Diode to protect the ECU against reverse connection.
« Last Edit: May 02, 2021, 11:54:08 PM by Kiwi_Roy »
72 Eldorado
17 V7iii Special
76 Convert

Moto Guzzi - making electricians out of riders since March 15 1921

Offline pauldaytona

  • Guzzi Hero
  • *****
  • Posts: 2523
    • Paul's fast Guzzi Page
Re: Instruments and ECU problems after long storage
« Reply #3 on: May 05, 2021, 12:59:18 PM »
This bike has no immobilizer, just as the newer v7 range. Could be a relais, it should click two when key on. If the power comes over the key lock. These bikes are so simple.
Paul

Daytona 1225, Stelvio 1151





Download Guzzidiag here: http://www.von-der-salierburg.de/download/GuzziDiag/

Wildgoose Chase Moto Guzzi

Re: Instruments and ECU problems after long storage
« Reply #3 on: May 05, 2021, 12:59:18 PM »

Online Kiwi_Roy

  • Guzzi Hero
  • *****
  • *
  • Posts: 9084
  • Location: New Westminster BC
Re: Instruments and ECU problems after long storage
« Reply #4 on: May 06, 2021, 12:26:32 AM »
This bike has no immobilizer, just as the newer v7 range. Could be a relais, it should click two when key on. If the power comes over the key lock. These bikes are so simple.
We will have to wait for Barefootrider to get back to us, once we know what the relays are doing it should be a piece of cake.
My monies on Relay 11 not picking up since the pump isn't priming although after that time it could be just the pump varnished up, I have seen that often.
« Last Edit: May 06, 2021, 12:33:07 AM by Kiwi_Roy »
72 Eldorado
17 V7iii Special
76 Convert

Moto Guzzi - making electricians out of riders since March 15 1921

***Wildguzzi Official Logo High Quality 5 Color Window Decals Back In Stock***
Shipping in USA Only. Awesome quality. Back by popular demand. All proceeds go back into the forum.
http://www.wildguzzi.com/Products/products.htm
Advertise Here
 


Harper's Moto Guzzi
Harper's Moto Guzzi. Where we still answer the phone, use the highest quality parts, and also do Transmission, rear drive, and carb rebuilds fast. Call us at 816.697.3411 and get your problems resolved.
http://www.harpermoto.com
Advertise Here