Author Topic: Guzzidiag Reader: Initialization Failed!  (Read 466 times)

Offline lewisham_phil

  • New Egg
  • *
  • Posts: 15
  • Location: London, UK
Guzzidiag Reader: Initialization Failed!
« on: November 24, 2022, 09:58:33 AM »
Hoping someone can help me in the battle to upload an ECU map to my 2012 V7 1TB Special:
I've bought the decent Lonelec connector, downloaded the V7-1TB-NoCat map from Mark at Griso.org, got a functioning Windows 10 laptop off Ebay, Got V.06 Guzzidiag, got the V.05 Reader and V.06 Writer, and also the recommended drivers (/CDM21228_Setup.zip):
However, I've fallen at the first hurdle! Using the Reader, after twenty seconds of saying 'connecting...' it comes up with 'Initialization failed' then 'turn off ignition for at least ten seconds', which when OK'd, closes the Reader.
I've made sure Guzzidiag isn't running; it's looking at the right COM port; turned off firewall and Virus software..  but it keeps doing it. It saves a small text file adjacent to the App each time this happens: Each one has ten lines of incremental time stamp in milliseconds, followed by FAST INIT.. (eg:  49394891ms FAST INIT )
I've done a web search, but it's not coming up with much; one mentioned trying 'slow init', but I can't see where to change this. Unless they were being funny, innit. :rolleyes:
I'm not sure what to try next, and would appreciate any ideas..
Thanks in advance.
CB200-RD350-GS550-CBX550-DT250-FZ750-RD250LC-ZZR600-CB919-XY400-Guzzi V7I Special

Offline 80CX100

  • Gaggle Hero
  • *****
  • *
  • *
  • *
  • *
  • *
  • Posts: 1418
  • Location: Ontario, Canada
Re: Guzzidiag Reader: Initialization Failed!
« Reply #1 on: November 24, 2022, 12:44:44 PM »
I'm not sure what type of safety switches,relays,ignition,ECU,wiring sequences are in that bike,but you might want to play around with different combinations if you're having trouble connecting to the ECU and getting it to read properly.

I recently used guzzidiag to adjust the CO trim on my 2003 V11 Lemans while it was up on the lift.

As the bike was warming up so I could do the adjustment,I happened to notice that the side stand was down. So with the best of intentions I moved the side stand from down to the up position,saying to myself, "I don't want that side stand safety switch to screw up my ECU/GD connection".

Sure enough,I lost the GD connection,and it took me 3 frustrating days,before I figured out that through some completely counter intuitive anomaly in the wiring,the only way GD will connect to the ECU on that bike is if the side stand is down.  AAaarrrggghhhh

fyi fwiw
2008 California Vintage
2003 V11 Lemans
2007 Griso 1100
1979 G5 & 1980 Lemans CX100
2010 Suzuki DR650 & 1978 SR500

In a time of universal deceit, telling the truth becomes a revolutionary act. George Orwell

Offline GuzziOrDeath

  • New Egg
  • *
  • Posts: 80
Re: Guzzidiag Reader: Initialization Failed!
« Reply #2 on: November 24, 2022, 01:44:49 PM »

First thing to try is the adapter test. It will confirm whether your cables are working.

https://www.von-der-salierburg.de/download/GuzziDiag/AdapterTest_V1.01.zip

Can you connect with GuzziDiag?


You might want to try changing the state of your kill switch. It shouldn't make any difference with a V7, but stranger things have happened.








Online Huzo

  • Gaggle Hero
  • *****
  • *
  • *
  • *
  • Posts: 12057
  • Location: Creswick Australia
Re: Guzzidiag Reader: Initialization Failed!
« Reply #3 on: November 24, 2022, 02:59:22 PM »
Are you absolutely certain you have the correct bike selected in the drop down menu ?
I once tried to re set the TGPS on the V85 for three hours with the Norge selected on Guzzidiag…. :embarrassed:

Wildgoose Chase Moto Guzzi

Re: Guzzidiag Reader: Initialization Failed!
« Reply #3 on: November 24, 2022, 02:59:22 PM »

Offline guzzisteve

  • Gaggle Hero
  • *****
  • *
  • Posts: 10747
  • "Just Ride It"
Re: Guzzidiag Reader: Initialization Failed!
« Reply #4 on: November 24, 2022, 03:16:55 PM »
That model is V7 II
"Pray through Carlo & your bike shall be healed"
Location: Planet Earth

Offline GuzziOrDeath

  • New Egg
  • *
  • Posts: 80
Re: Guzzidiag Reader: Initialization Failed!
« Reply #5 on: November 24, 2022, 04:16:14 PM »
Are you absolutely certain you have the correct bike selected in the drop down menu ?
I once tried to re set the TGPS on the V85 for three hours with the Norge selected on Guzzidiag…. :embarrassed:


Won't connect with the Reader, so that's irrelevant.





Online Huzo

  • Gaggle Hero
  • *****
  • *
  • *
  • *
  • Posts: 12057
  • Location: Creswick Australia
Re: Guzzidiag Reader: Initialization Failed!
« Reply #6 on: November 24, 2022, 08:44:05 PM »

Won't connect with the Reader, so that's irrelevant.
Ok.

Offline lewisham_phil

  • New Egg
  • *
  • Posts: 15
  • Location: London, UK
Re: Guzzidiag Reader: Initialization Failed!
« Reply #7 on: November 25, 2022, 05:43:14 AM »
Thanks for the replies guys. I've just run the Adapter Test, and it passes fine. Guzzidiag also connects fine; I have selected 'V7 Stone' as recommended in the instructions (mine's actually a V7 2012 1TB Special). Tried the Reader again (after quitting GuzziDiag), I notice the Transmit and Receive LED's on the Lonelec adapter flash every second (like they do when you run the adapter test), so seems to be connecting.. but same result,  Initialization failed.
What if I just try running the Writer, and upload Beetle's map? If I did need to go back to standard, I imagine it would be easy enough to find a standard original map? Although if the Reader isn't working maybe the Writer could wreak havoc!? 
CB200-RD350-GS550-CBX550-DT250-FZ750-RD250LC-ZZR600-CB919-XY400-Guzzi V7I Special

Offline Wayne Orwig

  • Gaggle Hero
  • *****
  • Posts: 13789
    • Hog Mountain weather
  • Location: Hog Mountain
Re: Guzzidiag Reader: Initialization Failed!
« Reply #8 on: November 25, 2022, 07:38:14 AM »
I would be reluctant to just write something to the ECU, and risk bricking it if there was a problem.

Which reader are you using? I sounds like you aren't using the correct one since the test works, and GuzziDiag works.
Scientist have discovered that people will believe anything, if you first say "Scientists have discovered...."

Offline lewisham_phil

  • New Egg
  • *
  • Posts: 15
  • Location: London, UK
Re: Guzzidiag Reader: Initialization Failed!
« Reply #9 on: November 25, 2022, 08:50:16 AM »
I'm running IAWMIUG3Reader_V0.0 5 , which is the one linked for 'the V7 & V9 Single Throttle Body MIU G3' in the instructions off the Griso.org site, which I think is up to date..
CB200-RD350-GS550-CBX550-DT250-FZ750-RD250LC-ZZR600-CB919-XY400-Guzzi V7I Special

Offline guzzisteve

  • Gaggle Hero
  • *****
  • *
  • Posts: 10747
  • "Just Ride It"
Re: Guzzidiag Reader: Initialization Failed!
« Reply #10 on: November 25, 2022, 10:27:03 AM »
I used the reader/writer last week although not your ecu I noticed it took a minute or so before I saw any green in the slot that shows progress.
I also had a charger on the battery, that's in case it takes some time and have optimum batt voltage for entire time it takes.
Seems you have the correct writer or reader. you could try just overwriting the map in there and get one later if need, like you said.
"Pray through Carlo & your bike shall be healed"
Location: Planet Earth

Offline lewisham_phil

  • New Egg
  • *
  • Posts: 15
  • Location: London, UK
Re: Guzzidiag Reader: Initialization Failed!
« Reply #11 on: January 02, 2023, 12:29:34 PM »
In the end I borrowed an obscure netbook running Windows 10, and that read everything just fine! Go figure. The next issue was that the supplied map wouldn't upload... doh, here we go again I thought. However, Mark (Beetle) soon sorted it out; apparently my map pre-dates his earliest copy of a factory map (2013). He had to build a new definition file to build the new map; It must be the first generation of the single throttle body V7 maps apparently. So I'm working through a few options at the moment. Very impressed with the service from Mark at Griso.org to build a suitable map.
« Last Edit: January 07, 2023, 03:24:25 PM by lewisham_phil »
CB200-RD350-GS550-CBX550-DT250-FZ750-RD250LC-ZZR600-CB919-XY400-Guzzi V7I Special

Offline moto-uno

  • Gaggle Hero
  • *****
  • *
  • Posts: 1296
  • Location: Burnaby , B.C
Re: Guzzidiag Reader: Initialization Failed!
« Reply #12 on: January 02, 2023, 01:53:54 PM »
  Glad to hear this , Mark was quick to respond to any problems I had with my 2018 Eldorado . I
must have reread everything 3 times before even trying and almost instantly had problems . I had to
add another port (#7 I think ) and it finally connected . The simplest things  :evil: . Peter

 

20 Ounce Stainless Steel Double Insulated Tumbler
Buy a quality tumbler and support the forum at the same time!
Better than a YETI! BPA and Lead free.
Advertise Here