Author Topic: ITI tacho displaying half speed with Sachse ignition  (Read 294 times)

Offline lazlokovacs

  • Gaggle Mentor
  • ****
  • *
  • *
  • Posts: 848
ITI tacho displaying half speed with Sachse ignition
« on: November 20, 2021, 01:33:02 PM »
Anyone know how the ITI electronic tacho works?

I'm sending it a signal from the Sachse ignition brain, but it's reading at half speed.

Weird thing is, even if I flip the switch on the Sachse unit (which is supposed to double or halve the signal) there is no change - the ITI keeps displaying at half speed.

Calvin 2008

Offline Kiwi Dave

  • Gaggle Hero
  • *****
  • *
  • Posts: 1396
    • Guzzi Gander Ltd
  • Location: Auckland, New Zealand
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #1 on: November 20, 2021, 01:40:40 PM »
I experienced this problem when replacing the stuffed speedometer on my California with a replacement.  My California was injected, but the replacement speedometer was meant for a carburettor version.  I think on the latter, the ignition fired on both strokes which is ignored by the motor, but obviously sensitive to the speedo.

Make sense?

Online Kiwi_Roy

  • Gaggle Hero
  • *****
  • Posts: 9369
  • Location: New Westminster BC
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #2 on: November 20, 2021, 10:14:19 PM »
The signal you send the tach must be just one cylinder and you need both.
It might be possible to combine the signals with a pair of diodes but I don't have the schematic for the Sachse unit
Can you point to a schematic showing a similar ignition
What have you changed, presumably it worked previously.
Sometimes the counter weigh drops off inside a tacho, shake it and see if it rattles.
« Last Edit: November 20, 2021, 10:23:27 PM by Kiwi_Roy »
72 Eldorado
17 V7iii Special
76 Convert

Moto Guzzi - making electricians out of riders since March 15 1921

Offline Scout63

  • Gaggle Hero
  • *****
  • *
  • *
  • *
  • Posts: 1473
  • Location: Orleans, MA USA
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #3 on: November 21, 2021, 07:34:44 AM »
My v50 Sachse EI box has a dip switch for selecting camshaft or crankshaft frequency. Here is a link to the manual:

https://www.gutsibits.co.uk/pr/TheShed/Downloads/SachseSaprisa.pdf

I hope this helps.
Ben Zehnder
Orleans, MA USA
1971 BMW R75/5
1972 Norton Commando Combat Interstate
1977 BMW R100S - next up to unload
1978 Yamaha SR500
1979 Moto Guzzi V1000G5 - T3FB mild custom
1979 Moto Guzzi V1000SP - on the lift

Wildgoose Chase Moto Guzzi

Re: ITI tacho displaying half speed with Sachse ignition
« Reply #3 on: November 21, 2021, 07:34:44 AM »

Offline lazlokovacs

  • Gaggle Mentor
  • ****
  • *
  • *
  • Posts: 848
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #4 on: November 21, 2021, 12:19:00 PM »
My v50 Sachse EI box has a dip switch for selecting camshaft or crankshaft frequency. Here is a link to the manual:

https://www.gutsibits.co.uk/pr/TheShed/Downloads/SachseSaprisa.pdf

I hope this helps.

Thanks mate,

like I said in my first post, that switch ain't changing anything, thats why I'm here asking....


Offline guzzista

  • Gaggle Mentor
  • ****
  • *
  • Posts: 923
  • Location: SF Bay Area
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #5 on: November 21, 2021, 12:51:08 PM »
Is it possible to wire tach signal directly from coil negative wires? maybe with in-line diodes as KR suggested?.
If the Sachse tach output is only used for that purpose and the bike runs without it it could simply be omitted
1975 750S Tribute bike, 1994 Cali 1100, 2007 Ducati GT1000, 1983 SP1000 1967 Vespa 180 SS, 1976 Vespa Rally 200

Offline Frenchfrog

  • Gosling
  • ***
  • Posts: 386
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #6 on: November 21, 2021, 02:42:16 PM »
I'd be tempted to send marco an email ...he's normally very quick in answering. info@elektronik-sachse.de

Online Kiwi_Roy

  • Gaggle Hero
  • *****
  • Posts: 9369
  • Location: New Westminster BC
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #7 on: November 21, 2021, 03:27:40 PM »
The manual clearly says.
DIP switch No. 2 should be in the up position for crankshaft frequency selection and down position for camshaft frequency selection: You need the Up position.
72 Eldorado
17 V7iii Special
76 Convert

Moto Guzzi - making electricians out of riders since March 15 1921

Offline lazlokovacs

  • Gaggle Mentor
  • ****
  • *
  • *
  • Posts: 848
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #8 on: December 02, 2021, 02:42:04 PM »
kiwiroy -

yes I set the switch in the up position - tacho reads at half speed

then I set the switch in the down position - tacho still reads at half speed

Online Kiwi_Roy

  • Gaggle Hero
  • *****
  • Posts: 9369
  • Location: New Westminster BC
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #9 on: December 04, 2021, 01:47:21 AM »
It seem to me when you have the switch in the Down position you would get pulses from 1 OR 10 showing up on wire 7
When you have the switch in the UP position you should get pulses from 1 AND 10
Is there any continuity between the wires 1, 10 & 7 testing with a multimeter, don't be surprised if there's not, it may be capacitive coupled
I could go on guessing until the cows come home
I think you may have to contact the factory, perhaps your unit is faulty.
Did it ever work as advertised?
Is the motor running on both cylinders, both heads getting hot?

 
« Last Edit: December 04, 2021, 02:00:54 AM by Kiwi_Roy »
72 Eldorado
17 V7iii Special
76 Convert

Moto Guzzi - making electricians out of riders since March 15 1921

Offline Old Jock

  • Gaggle Hero
  • *****
  • Posts: 2544
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #10 on: December 04, 2021, 03:47:19 AM »
Hi lazlokovacs

As all the other and you know it appears that the tacho was previously reading one pulse per revolution (crankshaft speed) and is now getting one pulse per two revolutions (camshaft speed signal) so its reading 1/2 revs.

Have you flicked the DIP switch  #2 up down a couple of times, I'm wondering if the DIP switch isn't making properly.

If you've got a scope or a DVM that reads frequency I'd check what pulse count you're getting from the Sachse unit with DIP switch #2 in both positions to confirm if that's where the problem is.

I'd also be try DIP switch #1 as well just to see what happens, it's only the rev limiter so it shouldn't be much of a big deal, but that's just me

What is an ITI tacho is that the electronic Veglia unit or something else?

John

Offline guzzista

  • Gaggle Mentor
  • ****
  • *
  • Posts: 923
  • Location: SF Bay Area
Re: ITI tacho displaying half speed with Sachse ignition
« Reply #11 on: December 04, 2021, 08:56:56 AM »
Just curious  as to  the outcome of this post as I am getting ready to install a Sachse ignition on my Cali 1100 (electronic Veglia tach and similar coils )
1975 750S Tribute bike, 1994 Cali 1100, 2007 Ducati GT1000, 1983 SP1000 1967 Vespa 180 SS, 1976 Vespa Rally 200

 

***Wildguzzi Official Logo High Quality 5 Color Window Decals Back In Stock***
Shipping in USA Only. Awesome quality. Back by popular demand. All proceeds go back into the forum.
http://www.wildguzzi.com/Products/products.htm
Advertise Here