Wildgoose Chase Moto Guzzi

General Category => General Discussion => Topic started by: lad on April 04, 2021, 04:16:26 AM

Title: Balancing Throttle/ Intake Ports
Post by: lad on April 04, 2021, 04:16:26 AM
Setting my TPS/ baseline as per
https://archive.guzzitech.com/EVTuneup-Jeff_B.html

i donít have a twin max, but i do have a carbtune, will that work? and is this the port i would tap into?


(https://i.ibb.co/SvS8MCB/A3-D9-A54-D-327-B-46-BD-B772-B4-D97-D28-FFA8.jpg) (https://ibb.co/SvS8MCB)
Title: Re: Balancing Throttle/ Intake Ports
Post by: Zoom Zoom on April 04, 2021, 06:13:55 AM
No reason that I know of your Carbtune would not work.

Yes, those are the correct ports. Originally there was a fitting for a hose. It appears those were removed and replaced with machine screws. So, you would need to put a barb fitting back in to connect your carb sync hoses to. What the previous owner did was certainly the more elegant solution. Many of us would simply use a cap or something on the original fitting to plug it off.

John Henry
Title: Re: Balancing Throttle/ Intake Ports
Post by: Wayne Orwig on April 04, 2021, 08:44:37 AM
Setting my TPS/ baseline as per
https://archive.guzzitech.com/EVTuneup-Jeff_B.html

i donít have a twin max, but i do have a carbtune, will that work? and is this the port i would tap into?


(https://i.ibb.co/SvS8MCB/A3-D9-A54-D-327-B-46-BD-B772-B4-D97-D28-FFA8.jpg) (https://ibb.co/SvS8MCB)


Yes those ports.

Twinmax sucks anyway. The carbtune is no doubt a much better tool then the spastic meter on a Twinmax.
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 04, 2021, 11:04:38 AM
IF you have some metric grease fittings. You can make a vacuum hose connector out of them. You need to remove the little ball and spring so that it's just an open tube. Some will unscrew to get the bits out. Others you may need to drill the end open more so the bits come out.

They may thread all the way in. If they don't, just a thread or two will do. Just needs to be snug, not very tight.
Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: pehayes on April 04, 2021, 12:49:43 PM
You're going to be tinkering with this adjustment for some minutes.  Make sure to mount a nice box fan up front to blow cooling air over the bike. 

Patrick Hayes
Fremont CA
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 04, 2021, 01:35:59 PM
Might have to rely on the cool weather and my windy location, Patrick.

The carbtune comes with vacuum ports so that's fine.

Can anyone explain this linkage thing to me? I see two bolts, the top one just seems to hold the thing in place? No idea what the side one does, but according to this write-up I need to tinker.


(https://i.ibb.co/BnRc3dy/IMG-6660.jpg) (https://ibb.co/BnRc3dy)


So I'm about to start at step 11, and I think I'll be fine until 14, when I have to adjust the aforementioned screws ? I also don't get how it can balance when I'll have just balanced at step 11 using the throttle body screws, then balanced again at step 12 using the airbleeds...?


(https://i.ibb.co/WtnL4cL/Screen-Shot-2021-04-04-at-19-30-31.png) (https://ibb.co/WtnL4cL)
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 04, 2021, 02:17:50 PM
In your picture, it looks like the LH TB.

Long screw above the nut balances the LINKAGE between the two TB's.

To fully set the TPS. You should have had to adjust the little screw at about 2 o'clock. That was the LH idle adjust. You set it first with the voltage of the TPS.

Step 11. Now move to the RH TB and you will see the same small screw that you adjusted on the LH TB. You screw that in until you get balance between the TB's.

When you open the air bleeds 1/2 turn, they will change the balance a little. Adjust them so that the TB's are in balance again and the reves are as mentioned.

Step 14. This is where you adjust the long screw I mentioned. The tie rod between the two TB's need to just slide back on. You don want it to move the lever when you slide it on. Well getting it over the tip of the pin may move the pin a very little, but it should return back. If it's adjusted too tight or loose, adjust the long screw. This step makes them open at the same time. Rev and hold the rev and get your balance reading, let idle. Adjust long screw and rev and hold again to get new reading, let idle. Repeat as needed.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 04, 2021, 02:45:40 PM
To start with a big  :thumb: for tackling this. I'm pretty sure I posted this link as well as the text only one:

https://bradthebikeboy.blogspot.com/2012/10/throttle-position-sensor-setting_21.html

This link explains what screws are what.

If in doubt when following the directions from here:
https://archive.guzzitech.com/EVTuneup-Jeff_B.html

Step back, grab your favorite beverage, smoke 'em if you got 'em, and think it through. It's a pretty easy job do, also easy to miss a step. ESPECIALLY for your first time. You just need to make sure you loosened the screws the instructions told you to loosen and adjust them in the order of the instructions.

If you don't think you have things right when your finished. Start over from the TPS voltage and work you way through.. You wouldn't be the first one that had to start again to get it right.

The long screw that balances the TB's at high rpm. If you have worked on multi carb bikes and had to make sure they were all open the same at revs. You most likely used a cable adjuster on each carb. The single screw is like the cable adjuster tha would have been on each carb. With this design, you only have to adjust one screw instead of each cable.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: Ncdan on April 04, 2021, 08:13:24 PM
I did my 02 Stone back in the fall last year. I got everything hooked up and one of the guys here on the forum walked me through the process step by step. Mine was off a bit and was able to bring it back to spec. Ran great afterwards.
Title: Re: Balancing Throttle/ Intake Ports
Post by: John A on April 04, 2021, 09:15:03 PM
Mig tips work as well.  Most are Metric  and I use the .030 wire size because thatís mostly whatís laying around.
Title: Re: Balancing Throttle/ Intake Ports
Post by: jcctx on April 05, 2021, 11:10:21 AM
If you have an infrared thermometer you just measure the temp as close to the cylinder as possible and get them equal. Far easier than hoses, etc.
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 05, 2021, 02:57:59 PM
To start with a big  :thumb: for tackling this. I'm pretty sure I posted this link as well as the text only one:

https://bradthebikeboy.blogspot.com/2012/10/throttle-position-sensor-setting_21.html



Thanks Tom,

I actually forgot about that blog post! I was just working off the text one, but they seem to do things in a different way/different order to each other, so I might just stick to the one and see how that goes, any trouble and I'll start query-ing.

The MV seems to be a prickly point, might see can I go by the degrees a-la-brad
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 05, 2021, 03:16:00 PM
The bikeboy link has pictures for the screws.

I would stick with the instructions in the text only link. That is the one I use. Worked every time. Well, except the first time :embarrassed: Did I mention the stand back with your favorite berverage :grin:

Also, in case your as electrically challenged as I am. Remember 500MV is .5V as in 1/2 volt. 525MV is .525 volt.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 09, 2021, 04:41:31 PM
This mv issue is highly contested

I was told 370, but...


(https://i.ibb.co/FbcHSJw/Screen-Shot-2021-04-09-at-22-33-22.png) (https://ibb.co/FbcHSJw)


Bradthebikeboy is way up there, compared to Jeff B, although he says the procedure is for the 1.5M.

I'm in a weird grey area where I have the older ECU with the newer TPS, I wonder should I try both mv's. ?  ?

Or go by degrees? I think I had GuzziDiag up and running ok, except there was no option for a P8/PF3C combo...

The weekend begs a few experiments either way
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 09, 2021, 08:28:25 PM
I just helped a guy with a P8 and PF3.

I followed Jeff B's guide. It worked. Use sewing needles, sewing pins, a broken in two paper clip to slide down the wires as the guide suggests.

DO NOT use Guzzidiad for the TPS voltage. Only use a multimeter! Make sure you see. "." in my voltage. As in "."150 volts.

With the PF3, back off all screws per Jeff B. With the plastic link bar undone and all screws backed off. "Adjust/rotate" the TPS to aprox. .150 Volts . .152 would be fine. Then tighten the TPS screws and leave them alone.

Then screw in the idle screw until you get aprox. .525 Volts. And then follow Jeff B's guide to balance the TB's and the air bleed screws. If you are unsure of the screws, look at the picture guide.

Sorry that your fighting with it. I had problems the first time. You will most likely have an  O crud moment, that is what the instructions mean.

If following Jeff B's instructions doesn't solve your problem, Then it is something else. The issue with a certain throttle grip position is usually the TPS

Setting the TPS isn't hard, you just need to do it right. Been there, done that!!!

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 10, 2021, 06:59:46 AM
Ok,

so the good news, the great fantastic news, is that the symptoms are gone! FIXED  :bow:

Not sure was it the TPS because I didn't baseline and balance with the old TPS, but more than likely it was. I'll hang onto the old one anyway and test it when I have too much free time.

The not great news is it's backfiring pretty bad, sounds like fireworks behind me after I accelerate.

Apparently this can happen after balancing and can be resolved by enriching the idle mixture at the trimmer?

Before I do that, I might just run the stats past your eyes in case it's my balance.

So the base is .150, but the idle (?) is then only set to .365 I think, as per PF09 instructions, so maybe I should raise it up to the .525 first?

Balanced throttles then, and set the idle too 1100, but this took about 1 and a 1/2 turn of the air bleed screws, which seems high compared to the instructions. I wonder if I'm set to .525mv and less air bleed would that sort it out?

It's not the worst to tinker with, mega thanks for the help on it, the sunny weather here now has a whole new prospect
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 10, 2021, 07:07:22 AM
Hmmmmmmm

I made a whoopsie...forgot to cap those intake ports, could well be the source of my lean mix....

Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 10, 2021, 09:02:42 AM
Made a bit of difference, still a bit of backfire when cruising after accelerating

I tried set mv to .525 but the idle was up at 13/1400 like that, that's with everything backed off and air bleed in. No way to lower it from that is there? Might have to go back to the lower, or hook up Diag and try by degrees....
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 10, 2021, 05:14:23 PM
Congrats, sort of!!! Your getting there!

Stick with .525.

You did make sure the plastic linkage between the TB's easily slid over the pin it goes on right??

If you followed the Jeff B instructions. I would back off the RH TB idle screw no more than 1 turn, less is better. That should get the idle down to the aprox. 1100 rpm. Or...Try turning in the air bleed screws a bit and see if that works.

When you  have it idling right.....

Use Guzzidiag to look at the fuel trim. Write down the number it shows in case you want to go back to it. With the engine up to temp, use guzzidiag to adjust the trim. I feel zero is what you would want. But......Try 10 increments and let it idle for a few moments, you will notice a change for better or worse. My EVT is +15, you might need more or less. If you need more than +40 with a stock bike, I would make sure your TB's and TPS are set right. Now you know how to do it, it only takes a few minutes.


Ooooopppppsss Forgot. P8. Try adjusting the fuel trim with the screw on the ECU. Just a little bit at a time. You will notice a change in idle in a moment or two. When your satisfied, ride and see how it does.
 :thumb:
Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: JoeB on April 10, 2021, 06:13:34 PM
Forgive me if I'm mistaken, but following your posts I think your dealing with the large p8 computer box?
Did you try any adjustments to the pot on the box?
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 11, 2021, 05:31:56 AM
Congrats, sort of!!! Your getting there!


You did make sure the plastic linkage between the TB's easily slid over the pin it goes on right??


yep, slipped on no bother.

I canít back out the RH adjuster, itís fully out, and the air bleeds are fully in, linkage is off, Ďchokeí is off, and idle is 1400 at .525
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 11, 2021, 05:38:26 AM
Forgive me if I'm mistaken, but following your posts I think your dealing with the large p8 computer box?
Did you try any adjustments to the pot on the box?
P8 yes, havenít done anything yet. was hoping it was set up right and wouldnít need messing there but itís my next stop. maybe valves first though
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 11, 2021, 06:04:53 AM
diag says iím only at 2.29 degrees on the throttle, so maybe .525 is the way, but then my idle is mad

CO trimm says 37. whatís the number about?
Title: Re: Balancing Throttle/ Intake Ports
Post by: Wayne Orwig on April 11, 2021, 08:12:08 AM
The P8 idle is 2.1 degrees, or about 385mv.
The 15M computer idle is 3.6 degrees, or about 525mv.
Both use 150mv baseline (idle stop backed out).
You should NOT be using 525mv at idle on a P8.

I'm not sure if Guzzidiag is displaying the trim pot value there or not.
Title: Re: Balancing Throttle/ Intake Ports
Post by: Zoom Zoom on April 11, 2021, 08:15:55 AM
maybe valves first though

Not maybe. Always.

John Henry

Title: Re: Balancing Throttle/ Intake Ports
Post by: pehayes on April 11, 2021, 10:28:11 AM
Ďchokeí is off,

Make sure to study the 'choke' linkage.  It is nothing more than a cam which causes a slight advancement of throttle.  You could do exactly the same by hand throttle, just not so gently.  It doesn't directly do anything to fuel mixture.  That mixture is 'computed' by your P8 and delivered via timed injector discharges.

I concur with Wayne.  Your P8 needs to be 385mV +/-.

Patrick Hayes
Fremont CA
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 11, 2021, 10:48:33 AM
Not trying to start something here, but.....

Is the .385 volts for a P8 with a  PF9 or with a PF3? Or does it not matter which TPS it is using?

I just helped a friend with a '98 with P8/PF3 (all screws backed out including the fast idle, bleed screws fully in, completely starting from scratch) and set the LH TB, TPS side to aprox. .385 volts. Tried to balance them. Wouldn't idle worth a damn.  Backed out the RH and set the LH to aprox. .525 volts. Now I was getting somewhere with the idle. Balanced the TB's with RH idle screw. That got me about 800 rpm. Adjusted  air screws to get about 1100 rpm and then set the linkage and balanced the linkage at about 3000 rpm. Now that bike was running sweet. There was no fast idle cable, so I did not adjust that screw, I just left it backed out.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 11, 2021, 11:11:45 AM
yep, slipped on no bother.

I canít back out the RH adjuster, itís fully out, and the air bleeds are fully in, linkage is off, Ďchokeí is off, and idle is 1400 at .525

When you set up the TB's. Did you also back out the Fast idle/choke screw? If that was making contact, it could be throwing off your adjustment.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 11, 2021, 12:58:02 PM
everything was backed out (air in).  i was the same as you Tom and couldnít get it to idle at all at .385, i had to have the RH in a touch, surprised that yours was so low with .525.

I just learned how to do it so i canít really trouble shoot. itís running quite well now apart from a backfire. back fire is cool no! ??
Title: Re: Balancing Throttle/ Intake Ports
Post by: Chuck in Indiana on April 11, 2021, 07:08:29 PM
Quote
back fire is cool no! ??
No.  :smiley:  I wouldn't go any farther until I adjusted the valves as recommended by others. That is square one before you start tuning.
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 12, 2021, 07:44:17 AM
No.  :smiley:  I wouldn't go any farther until I adjusted the valves as recommended by others. That is square one before you start tuning.

Yeah I think I'll do that, makes the most sense and they probably need to be done.
Title: Re: Balancing Throttle/ Intake Ports
Post by: Wayne Orwig on April 12, 2021, 08:01:19 AM
everything was backed out (air in).  i was the same as you Tom and couldnít get it to idle at all at .385, i had to have the RH in a touch, surprised that yours was so low with .525.

I just learned how to do it so i canít really trouble shoot. itís running quite well now apart from a backfire. back fire is cool no! ??

Something is off. Valve adjust maybe. Air leak maybe.
Do you have GuzziDiag?
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 12, 2021, 07:50:53 PM
Something is off. Valve adjust maybe. Air leak maybe.
Do you have GuzziDiag?

i do. for what?

i sprayed the rubber boots either side of the throttle bodies with starter fluid abs there was no perceptible change, in regards to an air leak
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 17, 2021, 05:56:15 PM
i did valves. left was at 15/22 (in/out) and right was 20/23.

i set them back to 10/15 as per the manual. a know people say 15/20 but iíll go back to stock and work from there.

Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 22, 2021, 03:43:04 PM
Not sure if anyoneís left but hereís an update,

after valves i decided to re-balance throttles. I checked my baseline was still .150 and then went with guzziDiag to set tps by degree, i went with 3.21, it was that or 3.03, nothing read in between, this translated to .475 on the multimeter.

from there, the balancing procedure went according to a various PDF plans, it was idling around 1100 with a half turn of the air bleeds.

After a ride, it was still backfiring, when downshifting mainly or rolling off throttle.

i had messed with the trimm a bit also, itís reading 67 on Diag.

when i got back i was idling around 13/1400. is it meant to be done with a warm engine? probably.

i might try reset the trimm to centre, but iíve to read up more on it, or iíll try find someone with a gas analyser.

i might redo the balance when warm, but i was happy with working off throttle degree. that said, maybe it was because of valves and i should go back to the .375 mv. too many variables
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 23, 2021, 12:25:56 AM
Not sure why your getting the backfire?? Loose header pipes/bad gasket, loose header to crossover or muffler?

The idle. You can try to adjust the bleed screws to bring the idle down. If that fails, you "could" back out the RH TB idle screw just a hair or two to get the idle down.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 23, 2021, 04:50:31 AM
Not sure why your getting the backfire?? Loose header pipes/bad gasket, loose header to crossover or muffler?

The idle. You can try to adjust the bleed screws to bring the idle down. If that fails, you "could" back out the RH TB idle screw just a hair or two to get the idle down.

Tom

would loose headers do it? and which gasket? i have a rattley exhaust at 2k rpm but canít locate it by hand.

wouldnít my bodies be out of balance if i just adjusted 1 ? iíll knock the airs in a touch and see

cheers
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 23, 2021, 10:27:13 AM
is this the gasket?


(https://i.ibb.co/4RkRT6M/14-C77-DC5-FF85-4-B96-8062-022-DD04-AFEAC.jpg) (https://ibb.co/4RkRT6M)
Title: Re: Balancing Throttle/ Intake Ports
Post by: Zoom Zoom on April 23, 2021, 10:36:11 AM
There is a gasket in the head where the header pipe goes. I **think** that is the one Tom was referring to.

John Henry
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 23, 2021, 10:44:18 AM
i get ya, this rusty looking fellow wedged in here? 


(https://i.ibb.co/n109MDx/5-EFE2123-5-A1-B-4872-BE33-1-CA64141-B6-B6.jpg) (https://ibb.co/n109MDx)


There is a gasket in the head where the header pipe goes. I **think** that is the one Tom was referring to.

John Henry
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 23, 2021, 10:53:27 AM
John, yes, the one where the header goes into the head.

Lad, The picture shows the cross over and is where a leak could be as well as where the muffler connects to the cross over. Also check the nuts that hold the header to the head. They sometimes come loose. A firm pull on the wrench is all that is needed, you just want them good and snug.

If you turn the RH TB idle screw out about 1/2 turn or less, it "probably" won't matter to the running balance.

Glad your making headway. Your bike is one where Guzzi introduced new parts and "I feel" there is not a definite answer to setting up the voltage/ throttle angle for the LH TB in a book. If you have it running well and getting decent mileage, let it be. OR...take some time and try the other options for the LH TB. You have experience now. IT will take less time to make the changes and go back if needed.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: Tom H on April 23, 2021, 10:56:41 AM
i get ya, this rusty looking fellow wedged in here? 


(https://i.ibb.co/n109MDx/5-EFE2123-5-A1-B-4872-BE33-1-CA64141-B6-B6.jpg) (https://ibb.co/n109MDx)


There is the outer clamp, a sleeve/spacer and then the gasket. IF you decide to dig in there, it may look like there is not a gasket in there. They sometimes look like part of the casting.

Tom
Title: Re: Balancing Throttle/ Intake Ports
Post by: Wayne Orwig on April 23, 2021, 02:10:59 PM
after valves i decided to re-balance throttles. I checked my baseline was still .150 and then went with guzziDiag to set tps by degree, i went with 3.21, it was that or 3.03, nothing read in between, this translated to .475 on the multimeter.

I thought you had a California 1100i, which has the P8 computer. On that you set baseline (butterfly closed) to 150mv, then crank the idle stop open to 385mv, or about 2.1 degrees on GuzziDiag.

Title: Re: Balancing Throttle/ Intake Ports
Post by: Wayne Orwig on April 23, 2021, 02:15:54 PM
i get ya, this rusty looking fellow wedged in here? 


(https://i.ibb.co/n109MDx/5-EFE2123-5-A1-B-4872-BE33-1-CA64141-B6-B6.jpg) (https://ibb.co/n109MDx)


The rusty bit is the metal 'plate' that presses the exhaust pipe into the head. The actual exhaust gasket is hidden behind the pipe and pressed into the head.
If it is a leak at the head, you typically hear the air leaking out.

It there is an aftermarket crossover, those often leak. There is no gasket down there. But I have fixed some by using aluminum shim (beer can) wrapped around between the inner and outer pipes.
Title: Re: Balancing Throttle/ Intake Ports
Post by: lad on April 23, 2021, 03:43:59 PM
I thought you had a California 1100i, which has the P8 computer. On that you set baseline (butterfly closed) to 150mv, then crank the idle stop open to 385mv, or about 2.1 degrees on GuzziDiag.

i do, but in a grey area with a PF3C TPS, i have been at the .385 mv and the .525 and neither stopped backfire, i went with 3.2 throttle degree after valves, just out of curiosity, as it was recommended in a tutorial, but i might swap back to the 2.1 now and see, iíll play around a bit with that and the CO trim and then look into a leak-down test maybe.

Actually hereís some sparks pics if anyone spots anything ...
(https://i.ibb.co/cv081sg/17-AB8-AA9-2-E07-4-CF2-8-FA7-2-ED2-BC795-FEE.jpg) (https://ibb.co/cv081sg)


left is left etc. these only have about 40km on them, but were pre-valve adjustment.

Getting there anyway, bit by bit, thanks again