Author Topic: Well That's Interesting. Distributor Rotor. Found The Issue!  (Read 527 times)

Online Tom H

  • Guzzi Hero
  • *****
  • *
  • *
  • *
  • *
  • Posts: 2591
  • Location: So. Cal.
I was dynamic timing one of my bikes. It seemed like my timing light was not working right. I was getting like a ghost spark and the timing marks were all over the place on one side. Even tried another light, same issue.

I decided it might be my old cap or the rotor.

I had a spare rotor and cap (no name set, not Marrelli), slightly used almost new pulled from a bike with running issues. I installed both and tried to start the bike. It would not start. I pulled a plug cap and grabbed a spare plug. It fired, but still the bike wouldn't start.

Hmmm......Well let's try the old rotor since it's the easiest thing to change back to. Old rotor in and it fired right up. New rotor back in, no start. Hmmm???

I looked at my old and the new rotor. Everything looked exactly the same, even measured it. Use my DVM and checked to see if the copper strip had continuity, all good. Checked for a short to ground from the strip, all good.

Damn thing should work!!!! I guess even when one looks good and is basically new, it could be bad. Maybe a lesson here somewhere??

BTW: the cap did seem to solve my timing light issues. Marks are now solid. Maybe the old cap was tracking or whatever it's called from dust or something.

Tom

« Last Edit: August 02, 2021, 07:32:43 PM by Tom H »
2004 Cali EV Touring
1972 Eldo
1970 Ambo V1000
1973 R75/5 SWB with Toaster
2007 HD Street Bob
1953 Triumph 6T (one day it will be on the road!)

Offline guzzisteve

  • Guzzi Hero
  • *****
  • *
  • Posts: 9774
  • "Just Ride It"
Re: Well That's Interesting. Distributor Rotor.
« Reply #1 on: July 28, 2021, 05:15:54 PM »
I have a box of old caps & rotors, just keep using them unless I have an issue. I clean up the strip on rotor and cut posts in cap. They last forever. I only put new stuff on someone else's bike.
"Pray through Carlo & your bike shall be healed"
Location: Planet Earth

Online elrealistico

  • New Goose
  • *
  • *
  • *
  • Posts: 68
  • Location: Central Florida USA
Re: Well That's Interesting. Distributor Rotor.
« Reply #2 on: July 28, 2021, 05:24:14 PM »
Clearance/resistance between the rotor end and the contatcs for the wires to the coils or plugs? Not familiar with the setup for that, but maybe too much gap on those or the center rotor to cap contact if it has one
2018 V7III Special
1978 T140V Bonneville

Offline Don G

  • Guzzi Mentor
  • ****
  • Posts: 910
  • Location: Smiley, Saskatchewan Canada
Re: Well That's Interesting. Distributor Rotor.
« Reply #3 on: July 29, 2021, 01:16:43 PM »
I had something like that happen to my 73 Eldo, lost spark ,so I grabbed the cap and rotor off of another running loop and that was the cure. DonG

Wildgoose Chase Moto Guzzi

Re: Well That's Interesting. Distributor Rotor.
« Reply #3 on: July 29, 2021, 01:16:43 PM »

Online Tom

  • Guzzi Hero
  • *****
  • *
  • *
  • *
  • *
  • *
  • Posts: 27822
Re: Well That's Interesting. Distributor Rotor.
« Reply #4 on: July 30, 2021, 04:09:02 PM »
Only thing out all of that is that maybe the length is not the same to make contact to the rotor cap.
From the Deep Deep South out in left field.  There are no stupid questions.  There are however stupid people asking questions.  🤣, this includes me.  😉

Offline CalVin2007

  • fickle old fool
  • Guzzi Mentor
  • ****
  • *
  • Posts: 762
  • Location: Central Kansas,USA
Re: Well That's Interesting. Distributor Rotor.
« Reply #5 on: August 01, 2021, 01:23:47 PM »
 To check to see if the spark is jumping downward through the rotor to the distributor shaft (it happens!) remove the cap,leaving the rotor in place. Pull coil wire end out of cap and hold 1/8" above rotor.Key on,crank engine. If the spark jumps to the rotor it's shorting through it to ground. If it doesn't jump it may try to jump to YOU so use something non conductive to hold the wire.
  Found this several times when I worked on cars for a living back in the dark ages... :wink:

  Terry
'07 CalVin
 '79 TT500
 '78 SR500
 '80 SR500

Offline moto-uno

  • Guzzi Mentor
  • ****
  • Posts: 947
  • Location: Burnaby , B.C
Re: Well That's Interesting. Distributor Rotor.
« Reply #6 on: August 01, 2021, 05:22:58 PM »
  And I'd agree with a previous remark that carbon tracking could easily prevent plug sparking and not be
too noticeable when taking a glancing look inside , good to get it running though . Decades ago I had
similar issues when trying to time a Le Mans 2 , to eventually find the drive gear on the end was badly
worn and introduced considerable wobble in the points cam . Replaced it and the timing was rock solid
from idle on up .  Peter

Online Tom H

  • Guzzi Hero
  • *****
  • *
  • *
  • *
  • *
  • Posts: 2591
  • Location: So. Cal.
Re: Well That's Interesting. Distributor Rotor.
« Reply #7 on: August 01, 2021, 09:25:59 PM »
Well I measured everything again. Seems the same dimensions as the working one.

Calvin, I think I might just try that with the bad rotor. Maybe that is why it will not run the bike.

FYI: To be clear. The bike seemed to be running fine, no issue I could notice, I was just trying to check the timing with a light. I was having an issue that I thought was my timing light. Bought a new one. Same issue. On my shelf was a newish , but used cap and rotor, new style no name.
Installed them and the bike would not start. Removed new rotor, installed old rotor. Started right up. ALSO, timing light issue was gone.
Installed the new rotor again to see what happens. AGAIN, no run.

I did clean the old cap with a toothbrush and Qtip. I will install it shortly and see if the timing light issue returns. If it does, bad cap. If gone, the cap needed the residue/dust removed from inside it.

Tom
2004 Cali EV Touring
1972 Eldo
1970 Ambo V1000
1973 R75/5 SWB with Toaster
2007 HD Street Bob
1953 Triumph 6T (one day it will be on the road!)

Online Tom H

  • Guzzi Hero
  • *****
  • *
  • *
  • *
  • *
  • Posts: 2591
  • Location: So. Cal.
Re: Well That's Interesting. Distributor Rotor. Found The Issue!
« Reply #8 on: August 02, 2021, 07:42:06 PM »
I put my old cleaned up cap back on with the old rotor. Fired right up. With my old timing light I checked to see if I still had issues with the lights advance adjustment. Worked like it should.

For S&G I put the new rotor in. No start. Tried CalVin's  idea and tested his way with the cap off. I had spark to the new rotor. Pulled new rotor and put my old one in. NO sparks.

It appears that the new rotor is being grounded somehow??? I tried my multi meter on the ohms setting to try to find the short. I'm not an electromagician, so maybe I missed something. I did try all the ranges on the meter.




So...For whatever reason, the rotor is shorting out the spark!

Edit: The new rotor would allow a spark at the plugs, but it was very weak looking. Probably because most of the energy was going to ground?

Tom
« Last Edit: August 03, 2021, 10:35:43 AM by Tom H »
2004 Cali EV Touring
1972 Eldo
1970 Ambo V1000
1973 R75/5 SWB with Toaster
2007 HD Street Bob
1953 Triumph 6T (one day it will be on the road!)

Online nc43bsa

  • Guzzi Mentor
  • ****
  • *
  • *
  • *
  • *
  • Posts: 950
  • Location: Mooresville NC
Re: Well That's Interesting. Distributor Rotor. Found The Issue!
« Reply #9 on: August 03, 2021, 12:38:55 AM »
As mentioned previously, the spark is probably grounding through the plastic of the rotor to the rotor shaft.  A multimeter will not detect this.
1990 MilleGT

 

***Wildguzzi Official Logo High Quality 5 Color Window Decals Back In Stock***
Shipping in USA Only. Awesome quality. Back by popular demand. All proceeds go back into the forum.
http://www.wildguzzi.com/Products/products.htm
Advertise Here