Author Topic: Today's ride, spiked with strange random moments... help reading them?  (Read 903 times)

Doppelgaenger

  • Guest
So today is the first day I have taken the Breva for a ride on a properly warm day (75 degrees is in fact considered warm in seattle) and while the bike ran pretty much OK, there were a few strange moments that have me wondering if something is wrong.

Since it's gotten warm enough to ride without a balaclava, I have been noticing a more clickety sound from the engine, enough for me to voice my concerns at Moto International when I bring the bike into them on saturday for a tire change, but not enough to have taken any action. In part because I'm hearing the bike more now that I've removed the balaclava from in the way of my ears.

So today, warm day, I go for a ride and I was going down a road, downhill most of the way and gave a good dose of throttle just for fun. Once the engine passed 5000 rpm I got an healthy and unexpected surge in power that only lasted a moment. At the time I didn't think too much about it.

Then about a mile later I came to a stop and there was a lot of traffic so I had to wait. About a minute waiting for a break in the cars, the engine suddenly slowly dropped the revs until it did a chug-chug-chug-stall.

I thumbed the starter and it started right back up just fine. I rode another 30 miles and stopped at least 50 times after that and the bike never missed a beat. It did ping on me once after that on hard throttle but I had just been riding thru a neighborhood at about 20 for some 10 minutes, I know the bike will ping when it's very hot.

Any ideas with the slow engine stall? Is this just one of those elements of the famous "character" of italian vehicles? Has anyone experienced this?

Offline twodogs

  • Guzzi Mentor
  • ****
  • *
  • *
  • *
  • Posts: 446
  • Location: ia
Old gas maybe? Here in Iowa I usually have to run about 2 full tanks through to get rid of the Stabil gas, after that mileage improves and the bikes run better :bike
2019 Suzuki Burgman 400

Offline M0T0Geezer

  • Guzzi Hero
  • *****
  • *
  • Posts: 567
    • The Ones I Rode
  • Location: Sun City West, AZ
My thought is that your gas tank vent is clogged, making a vacuum and starving the injectors.

This is more likely at idle, especially  after a speed run.

Does your fuel filler have a sucking sound when you pop it open? That's a sure sign you have a clogged vent.

'Geezer
2007 Moto Guzzi Norge 1200 USA

My 65+ years of motorcycling here:

http://www.dansher.com/mywheels.htm

Wisdom from the road:

http://www.dansher.com/bikequotes.html

Play guitar or keyboard?  You will like:

http://www.dansher.com/audio/pdf_tunes.html

 

***Wildguzzi Official Logo High Quality 5 Color Window Decals Back In Stock***
Shipping in USA Only. Awesome quality. Back by popular demand. All proceeds go back into the forum.
http://www.wildguzzi.com/Products/products.htm
Advertise Here